Sunday, May 22, 2016

CAUTION ! When update is critical

Long long time since my last post.
I'm still around but very very busy with the job and other activities.
I have many projects that needs my attention, halted, waiting for better time.

Among the many things I have to do and I'm doing, after long time I decided that it was necessary to finally upgrade my server from the 15.04 Ubuntu to the latest LTS Ubuntu distro, the 16.04 LTS.
As usual when there is an upgrade, not the usual update, I'm always quite nervous.
In the past almost every time I ended up to format everything from the scratch since the upgrade always failed along the way.

So after the usual backup of data, I started the upgrade.
First I had to upgrade from the 15.04 to the 15.10.
It took about 3 hours and I "lost" only a couple of services.
Then, since the system was still working I decided to risk everything and upgrade from the 15.10 to the 16.04 LTS.

It worked ! It took an additional couple of hours crunching, deleting old libraries, clean up the system, upgrade configurations but it worked.
But I had to pay a price.

After restoring the broken services, sometime simply re-installing a new version, I discovered that ALL my websites based on Joomla hosted on the server, were off line.
Dead. All dead.

Ubuntu 16.04 LTS installs ONLY PHP 7.x. Older versions of PHP are not supported, actually the notes suggests to DON'T Try to install PHP 5.x at all.
And my Joomla websites were bases on old versions of Joomla, requiring PHP 5.x or even older ones.

Only Joomla 3.5 supports PHP 7.0 so I ended up with very few choices :

  1. erase the Ubuntu 16.04 LTS from the server and install something older
  2. try to install other PHP versions other than the 7.x on the server
  3. install virtualbox on the server and set up a old version of Ubuntu only for the web servers
  4. install Joomla 3.5 and rebuild all the websites converting from the old versions
Let's cut the suspance :) in the end I opted for the last option.
Ubuntu 16.04 LTS works really nice on the server, the only flaw is PHP.
So far the server is much faster and stable than before.
Installing older version of Ubuntu was not really a choice.

The choice number 2 required to have a lot of time to overcome the errors certainly coming out as well as the choice 3.
I did try to install virtualbox but I ended up with errors.
The version I tried to install was incompatible somehow with the 16.04 and not yet enough support or other people doing that to find solutions fast.

So I decided to recreate all my websites from the scratch, using Joomla 3.5.
It will take some time to convert the data (I'll maybe write another article to describe the pain for this operation :) )  but in the end is the least expensive, safest way to proceed and I'll end up with a better working websites.

So, if you are planning to upgrade your machine to Ubuntu 16.04 LTS and you need PHP 5.x or older ... BE VERY CAREFUL.
You'll lose a lot but also gain a lot from other areas.